Toyota Prius Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I was told by my Toyota service center that my '05 Prius with 211K miles on it has a wiring harness that is corroding and will need to be replaced to a tune of $6ooo. I all started this past Saturday with a dealer service (oil change and tire rotation). Yesterday while I was driving home the Check Engine light came on. This happened before and it turned out to be a low oil condition. I pulled over and check the oil. First cleaning off the dip stick and then re-inserting it. It came up showing no signs of oil. I called service and they said to tow it in which I did. Today the called me saying the the oil was full and that I must not have seen the level because it was "crystal clear". I asked if it came with new clothes for the emperor but she didn't get the reference. I am 47 years old and have done all the maintenance on my vehicles prior to this so I think I can tell no oil from new oil. I asked what the CEL suggested and I was told that the wiring harness was corroded. In all my life I have never had or heard of a wiring harness corroding. They said that another '05 was in the shop with the same issue. Is this common for the '05 Prius? I plan to get a second opinion from a mechanic I trust but wanted to search the web for other instances.
 

·
Registered
Joined
·
2,243 Posts
I haven't heard of wiring harness problems outside of salvaged or otherwise damaged vehicles. What were the codes pulled by the dealer?
 

·
Registered
Joined
·
19 Posts
I was told by my Toyota service center that my '05 Prius with 211K miles on it has a wiring harness that is corroding and will need to be replaced to a tune of $6ooo. I all started this past Saturday with a dealer service (oil change and tire rotation). Yesterday while I was driving home the Check Engine light came on. This happened before and it turned out to be a low oil condition. I pulled over and check the oil. First cleaning off the dip stick and then re-inserting it. It came up showing no signs of oil. I called service and they said to tow it in which I did. Today the called me saying the the oil was full and that I must not have seen the level because it was "crystal clear". I asked if it came with new clothes for the emperor but she didn't get the reference. I am 47 years old and have done all the maintenance on my vehicles prior to this so I think I can tell no oil from new oil. I asked what the CEL suggested and I was told that the wiring harness was corroded. In all my life I have never had or heard of a wiring harness corroding. They said that another '05 was in the shop with the same issue. Is this common for the '05 Prius? I plan to get a second opinion from a mechanic I trust but wanted to search the web for other instances.
Let me tell you what I know about dealers and you could decide for yourself. According to Forbes magazine, the dealers' profit margin from servicing is somewhere around 50% while selling new cars is less than 10%. My dealer gave me the impression that they don't like selling Prius and I think I know why. It's a long lasting and reliable car. These characteristics are good for the buyers but not good for the dealers' revenue. A lot of dealers out there also hate selling Electric Vehicles because they can't make money on services like oil change.

If I were you, I would get a second opinion before throwing money at the dealer.
 
1 - 4 of 4 Posts
Top