Toyota Prius Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
508 Posts
Discussion Starter · #1 ·
Yesterday, I noticed my volume and mode buttons (top left quadrant) no longer have a noticeable "click" feel. They work, but they don't have any physical feedback when you press them.

Anyone know if this is a sign that they're about to fail, or if they're going to continue to work, but they're just going to feel mushy from now on?

Will this be a warranty repair item, or a non-covered wear-and-tear item?
 

·
Registered
Joined
·
610 Posts
:roll: What model Prius and how equipped. It is always helpful to provide details if you are requesting information or help.... even your geographical location. Otherwise, we can only guess.
 

·
Registered
Joined
·
508 Posts
Discussion Starter · #3 ·
'04 Package 9. Blue. Geographical location is right there on my profile.
Coastal XM, EV, and Door Lock.
Steely Dan in the CD changer, full tank of gas, half pack of cigarettes, it's dark, and I'm wearing sunglasses.
Pardon the initial lack of info. I assumed there wouldn't be that much variation in basic steering wheel button part construction.
Was the eye roll emoticon really necessary?
 

·
Registered
Joined
·
457 Posts
Tom,
I had to go get in the car to see what the "feel" on those buttons is. Mine have sort of crisp feeling when pushed but, as you described, no click. I use them a lot and I'd make this known to my dealer on the next visit.
The 3 Yr/36K mi. warranty should cover the problem IF THEY FAIL. I'd presume the mushy feeling isn't covered.
BTW.. In S. CA, sunglasses after dark is reserved for celebrities who don't drive.. ~JD~ 8)
 

·
Registered
Joined
·
2,285 Posts
I am concerned about those buttons, too. I use them ALL the time! I have to think I'm going to wear them out, and it will cost a bundle if they fail after the (extended) warrantee. I just don't see anything I can do about it. I keep cars a long time, so maybe by the time they fail there will be junkyard parts available.
 
1 - 5 of 5 Posts
Top