Toyota Prius Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
After a year of faithful service, our Prius has decided to misbehave occasionally. About 10% of the time you get out of the car and close the door, it beeps 3 times and will not lock using the door handle button. The manual suggests that this means the car is still in gear. It is the same beeping behavior seen when you put the car in park but leave it running, and you and the key fob get out to get the mail.

The dealer says there are no trouble codes logged. We can not get the problem to replicate at the shop, so they are unable to fix it. Their suggestion is that some RF field is causing the problem, but that seems unlikely because there is no pattern of locations or driver where the problem shows up.

The only other strange thing I have noticed is that sometimes when the car is locked, it does not unlock right away when you touch the handle. If you back away from the vehicle and try again it will work.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
The fob was in the pocket or purse as usual. As a test, I put the fob 30+ feet away and shut the door. Same 3 beeps. Fetching the fob and trying to lock the door did not work. If you shut the door and hear the beeps, the only way to lock or unlock is with the key.

I saw one message on one of the boards about a similar problem. The solution there was to "reset a computer". The dealer said he reset all the computers, but I do not know if I believe it.
 

·
Registered
Joined
·
2,285 Posts
Your fob battery may be getting weak. It takes loittle juice to light the LED on the fob, but the RF transmissin takes more. Try replacing the fob battery.
 

·
Registered
Joined
·
111 Posts
I think there is a 3 second delay before you can unlock the door, after locking it. Your hand could be on the handle when locking the door.
 

·
Registered
Joined
·
1,233 Posts
Hmm, what I usually do is get out, place one finger on the lock button and press that as I close the door. This way, it'll lock when the door closes. Problem is, sometimes, it'll beep but the door didn't lock.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
We replaced the bettery in both fobs, but it did not make a difference.

Usually if you get out and close the door there is no beeping. You can push the handle button anytime after the door is closed and it locks.

The problem we are having is that when you get out and close the door, you get 3 beeps. At this point, the car will not let you lock or unlock using the button or under-handle grip.

Somehow the computer thinks the car is on or maybe not in park. It will not let you lock the door in this mode. It is easy to get all the symptoms, by putting the car in part but leaving it on. Get out, taking your fob with you. Close the door (3 beeps) and walk away. If you try to hit the lock button it will not do it.

It sure is strange.
 

·
Registered
Joined
·
370 Posts
Does it still misbehave when you turn Smartkey off?

When it refuses to lock via the black button, will the fob lock it?

My other question would be: Does it matter at all where the car is parked, or does it happen anywhere? The reason I ask that is because one time someone mentioned that certain sensors at Home Depot was interfering with their Smartkey system. I believe it was the inventory control sensor located near the door. Maybe you neighbor's ham radio is wreaking havoc.
 

·
Registered
Joined
·
7,161 Posts
Tideland Prius said:
Hmm, what I usually do is get out, place one finger on the lock button and press that as I close the door. This way, it'll lock when the door closes. Problem is, sometimes, it'll beep but the door didn't lock.
Door needs to be closed when pressing the lock button on the door.
 

·
Registered
Joined
·
7,161 Posts
3 beeps according to the user manual indicates the car has not been turned off or put into park before locking the door, and the fob was not found to be in the car.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
dgstan:
It has the same problem when I turn off smartkey with the button under the dash.
The lock/unlock buttons on the key fob do not work, but panic does.

As for location, that was the dealers guess. I have not found any place where it breaks. It does seem to run in streaks though. If it is messed up at home, it will be messed up for the next 2-3 stops. About the only place it NEVER messes up is at the dealership....
There are no ham's near my house, just lots of 802.11. It has not messed up at home depot despite the amount of time I spend in thier parking lot.


DanMan:
I sat in the car while my wife messed closed the door wand walked away, and there is a long beep inside the car in addition to the three external beeps. This matches the user manual description you quoted. The text in that section is very odd though, and I wonder it there is a third reason that got lost in translation.

Anyway, this is a very strange problem.
 

·
Registered
Joined
·
669 Posts
Do both fobs have the same problem? Does the car believe it is in Park when you shut it off?
 

·
Registered
Joined
·
67 Posts
Is it possible that your trunk is not securely latched, or a door is not properly closed? I believe I have had similar symptoms when I haven't had the trunk properly latched.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
The problem happens with both fobs equally.

I will check the trunk next time. The door open light is not on, but it can not hurt to slam the trunk and see if the problem goes way. Thanks!
 

·
Registered
Joined
·
669 Posts
I'll ask this again -- when you go to shut the car off, is the green park light on and does the car indicate "P"? If there is something wrong with the circuitry that captures the drive state, it could explain what you describe... I think!
 

·
Registered
Joined
·
40 Posts
Do you have both fobs with you when you use the car? When my husband and I both have our fobs with us, one of us has to walk away from the car before the locks will behave properly.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #17 ·
When the problem is happening, I am sure the car is in park and the light is on. In fact, I can turn the car on, never go into gear (park light stays on), and turn it off again. It will ALWAYS have the problem. It seems that one requirement for the problem to go away is that you actually drive some distance. So far, just moving a few feet has never fixed it.

On the fobs, we have both had it happen to us when we are by ourselves, and had it happen when we are together.

The trunk not being quite closed in my best hope so far.
 

·
Registered
Joined
·
7,161 Posts
If you have to drive a distance, then there may be a radio tower nearby causing interference. We have seen one report of that where SKS would not work in a particular parking lot.
 
1 - 18 of 18 Posts
Top