Toyota Prius Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Overheating after full tuneup and Blue Devil. At 120k miles she started having some bad engine rattle, only upon startup at first, and then it progressed to start doing it at stops and slower speeds....but once she was up in the gears and running at speed she drove perfectly fine....but having it checked the first guy said it was definitely motor mounts. This didn't make sense so me so I had 2nd opinion at Midas and they ran codes and said it's calling for new plugs and wires (they were original, so it made sense). They wanted $1600 to do plugs and wires which seemed outlandish to me. So I took to shade tree mechanic (he seems like a real good guy and my gut tells me he's honest) and he said the same that the codes were calling for full tuneup. So after ordering parts and having him do the tune up the engine rattle was still there. Same behavior. He then said it's very likely a blown head gasket, and we all know that's not cheap. So he offered an option to gamble and try the Blue Devil - he says he's had similar situations and BD worked perfectly and gave a number of years on the car. So I had him do it and WALA!! She ran like brand spankin new!! For one day. Literally drove perfectly all day - (I maybe did 3 trips back and forth across town, etc.) The next day (she sat for almost 24 hours after that perfect day) I got in and drove into town and halfway there she is running extra extra hot and the dash is telling me all sorts of scary stuff about STOP VEHICLE, CHECK HYBRID SYSTEM, Warning Triangle, temp warning, etc etc. What is this !?!? I can't afford a big ticket job right now I'm looking for DIY solutions. I'm moderately capable myself or have a good honest cheap mechanic who can help. Thanks for advice in advance everyone!
 
1 - 1 of 1 Posts
Top