Toyota Prius Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter · #1 ·
My brother has a 2004 Prius (I have the 2005). He called me to say that his NAV screen is totally screwed up. He can't access any of the menus in any category. He has a service scheduled in a couple of weeks, but I'm wondering if there's any quick-fix to this problem (like, say, a re-boot).

Anyone else ever had this problem?
Any ideas how to remedy it?

Thanks in advance!

marlowe
 

·
Registered
Joined
·
1,434 Posts
Hope he's still in the 3yr/36k mile window....the MFDs on a number of the '04s need to be replaced and they're covered under the 3/36 standard warranty. It's also covered under the extended warranty if he purchased that.

A few have successfully appealed to Toyota to replace the MFD for free since it is a known issue and since it isn't due to wear and tear and certainly should not go out this early.
 

·
Registered
Joined
·
7,161 Posts
Early 2004's (produced before June, maybe July 2004) would develop screen problems especially if they were cold. TSB EL002-05 documents this.

If your brother couldn't toggle between the energy and consumption screens using the INFO button on the steering wheel, then he has the older, problematic display. If he could toggle between them, then he probably has the newer screen that fixed the problem.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top