Toyota Prius Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
My MFD is a multifunction display any more, in fact it’s no function display.
It started cutting in and out yesterday, the radio stopped, the display froze and then it would come back on. Now the screen just says something like, “Check System Function”
 

·
Registered
Joined
·
515 Posts
It is most likely the TSB: EL002-05

Early models of the HSD Prius and some Land Cruisers & Highlanders will sometimes require the revised Multi-Display. Your dealer will order you a free replacement once they confirm that's the problem. That happened to me. It was a painless fix, and all has been well since. (In fact, my "Info" button got upgraded as a result too. It now toggles screens like the newer HSD Prius do.)

Also note that MFD is not proper terminology. The TSB clearly refers to the touch-sensetive screen as a Multi-Display.
 

·
Registered
Joined
·
2,237 Posts
Diana_04Prius said:
My MFD is a multifunction display any more, in fact it’s no function display.
It started cutting in and out yesterday, the radio stopped, the display froze and then it would come back on. Now the screen just says something like, “Check System Function”
Get it replaced. I had one of my customer's car with the same symptom
and Toyota service swapped it with a new one.

They said a few bad badges went in to assembly line and it is circulating
around somewhere in the US ! It should be under the warranty 3/36 ?
 

·
Premium Member
Joined
·
2,815 Posts
It's happening on 2004 Highlanders and Land Cruisers with the
Navigation system, and on 2004 Prius with or without the Navigation
system. There are different part numbers for the Nav and non-Nav
Prius displays, so if you are having problems make sure your dealer
orders the correct one for your car...

http://autos.groups.yahoo.com/group/toy ... 002-05.zip
or
http://www.alldata.com/tsb/Toyota/11053 ... index.html

To quote US TSB EL002-05:
<quote>
Some customers may experience various malfunctions occuring in the
multi-display. Some examples are:
* "Audio off" is shown on audio screen while the audio system is
playing.
* Climate control is not responsive and may say "Check connection of
the air conditioner."
* Map, Destination buttons are inoperative and may display "External
system not connected."
* When pressing any button on the multi-display, the system takes 5
to 10 seconds to respond to the user's input.
* Outside air temperature not displayed.
</quote>

Prior reports on various Prius boards have noted other Classic Prius'
Newarkitis symptoms: no charge on the battery icon, no arrow flows on
the Energy Monitor, a "stuck" Consumption screen showing many
consecutive 100MPG (or 0 l/100km) segments even with the engine
running at idle... It will occur randomly at first, but will get
progressively worse. It's only covered for the basic 3 year/36,000
mile warranty, so be careful if you're going past on mileage as it
could be very expensive... Car is fully driveable, but it's mostly
an annoyance. A reboot may temporarily fix the problem. Problem has
been reported on US, Canadian, and Australian Prius so far that I've
noted, I don't recall one way or the other on the European/UK lists...

Here's some photos taken by an Australian Prius owner of what's occuring: http://www.trufit.com.au/Prius/ScreenUnitFailure/

The car is safe to drive while waiting for the part (usually on
backorder these days). Usually the buttons on the steering wheel work
best when trying to change things and the display is acting up.

The good thing is that if you have a pre-April 2004 Prius with the
navigation system, the new display will change the Info button on the
steering wheel to toggle between the Energy Screen and the Consumption
Monitor.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #5
"Audio off" is shown on audio screen while the audio system is
playing.
Does that.......

Climate control is not responsive and may say "Check connection of
the air conditioner."
Does that.......

Map, Destination buttons are inoperative and may display "External
system not connected."
Does that.......

When pressing any button on the multi-display, the system takes 5
to 10 seconds to respond to the user's input.
Does that.......

Outside air temperature not displayed.
Does that.........

Hmmm......... I guest I will be making a phone call first thing Monday morning.
And I do have the Nav System and the date of manufacturing was 11/3/04 :(
 

·
Registered
Joined
·
46 Posts
Mine just started doing the same thing. All of the manfunctions noted above were experienced. Also the bluetooth system is affected. The button on the wheel will answer the incoming phone call but no audio in or out is heard.
Part is on order at the local stealership.

Mike
 

·
Registered
Joined
·
35 Posts
Sticking buttons?

I had read elsewhere that some people had odd behaviours from their displays due to a sticking "Climate" button - which is an apparent defect of the older MFD. It would then inundate their system with millions of inputs, enormously slowing down the display. The temporary fix was to check their buttons and make sure none was depressed - permanent fix was to replace.

Could it be something similar here?
 

·
Registered
Joined
·
75 Posts
Discussion Starter #8
I went to the dealers on May 16th and they agreed that that was the problem and they were ordering the part. Well, I just called them up to find out when the part was coming in and they said, “What part?” So now it is back to square one and they are just ordering the part now.
#&%##!!!…………… :x :x :x :x
 

·
Registered
Joined
·
319 Posts
Ask the service manager for a good reason why you should ever come back. Tell us what is told to you...
 

·
Registered
Joined
·
75 Posts
Discussion Starter #10
The are FedEx'ing it overnight delivery from the west coast and he was very apologetic. Over all, I must say this dealership has had a good track record with me. Every problem that I had ( mostly it has been TSB or routine maintenance ) they fixed it right away and in the time they said they would without any hassle.
 

·
Registered
Joined
·
40 Posts
I have a display failure with all of the symptoms above on my 04 with over 100k miles so I'm not under warranty anymore. My question is if I take it to the dealer are they going to charge me to do a diagnosis that tells me what I already know? Should I just order the part from the dealer and have them install it? Seems like if it's a known problem Toyota would have replaced it under a recall but that didn't happen.
 

·
Registered
Joined
·
1,434 Posts
Fordman789 said:
I have a display failure with all of the symptoms above on my 04 with over 100k miles so I'm not under warranty anymore. My question is if I take it to the dealer are they going to charge me to do a diagnosis that tells me what I already know? Should I just order the part from the dealer and have them install it? Seems like if it's a known problem Toyota would have replaced it under a recall but that didn't happen.
I think I'd start with a phone call to the service dept. and see how they respond. Call them with a clear description of the symptoms, tell them how it matches the TSB (have the number ready so they know you know what you're talking about). See what they say.

The TSB does, however, indicate some things that should be checked before declaring the MFD dead, so I wouldn't be suprised if they have you bring it in for a diagnostic check...if so get it clear up front what that will cost you. Also make sure they order a refurbished MFD..should be around $700...new will be close to $3000.

Let me add that you have another option...buy one from Ebay..a salvage. One on there now for $950 (which seems darn high for a salvage IMO):
http://cgi.ebay.com/ebaymotors/TOYOTA-P ... enameZWD1V
Then you could install it yourself or have the service dept. or any decent car stereo installer do it for you...it's not a difficult project.
 

·
Registered
Joined
·
591 Posts
I thought Toyota could get used ones for $400ish? I base this on previous owners reports posted on this and other forums.
 

·
Registered
Joined
·
1,434 Posts
David Beale said:
I thought Toyota could get used ones for $400ish? I base this on previous owners reports posted on this and other forums.
Apparently the price has gone up of late...not to mention the refurbs can be hard to get.
 

·
Registered
Joined
·
40 Posts
Also make sure they order a refurbished MFD..should be around $700...new will be close to $3000.

Let me add that you have another option...buy one from Ebay..a salvage. One on there now for $950 (which seems darn high for a salvage IMO):

If I'm going to have to pay for diagnostics, then $700 to $950 for a used one or $3000 for a new one I think I can live with it the way it is for a while. I have two daughters in college and the money tree in the backyard is a little bare right now. Thanks for the replies.
 

·
Registered
Joined
·
2,348 Posts
Fordman789 said:
Also make sure they order a refurbished MFD..should be around $700...new will be close to $3000.

Let me add that you have another option...buy one from Ebay..a salvage. One on there now for $950 (which seems darn high for a salvage IMO):

If I'm going to have to pay for diagnostics, then $700 to $950 for a used one or $3000 for a new one I think I can live with it the way it is for a while. I have two daughters in college and the money tree in the backyard is a little bare right now. Thanks for the replies.
We should all turn off our MFDs for a few days to remind ourselves that it isn't necessary for making the car go.
 

·
Registered
Joined
·
1,028 Posts
Intrepid owners of a failed MFD might pay a dealer to remove the unit, then disassemble and repair it themselves by re-soldering the flawed connector, then pay a dealer to re-install the unit.
 

·
Registered
Joined
·
40 Posts
I called Bellvue Toyota and for $90/hr they can run diagnostics and tell me my MFD needs to be replaced, which I already know. A new one runs $4500, they have no remanufactured ones but I might be able to get one in Kansas City. I can drive it as-is but with no dependable heater controls. As long as I have them set where I want them and don't change anything I should be ok while I look for an affordable fix.
 
1 - 20 of 23 Posts
Top