Toyota Prius Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Recently, my 2007 Prius has been starting and running normally, but backup camera, Consumption graph and all dashboard lights are non-functional intermittently. What could affect all three of those systems? Has anyone experienced this anomaly?
 

·
Registered
Joined
·
35 Posts
I ,occasionally, have had that problem with my 2005 Prius. Some have said to replace a certain capacitor on one of the circuit boards. Others have just put it into diagnostic mode and then back out and it seems to reset the displays and then it works. Not safe to drive without them as you can't see some important things, like speed, warning lights, fuel level, etc. etc. If you do a search on google there are a few quick videos that show you how to do that and it takes only a couple of minutes. I sometimes have had to do it ore than once before it resents but then will last months before it happens again. A lot easier than having to tear your dash apart just to replace a capacitor! Now, if for some reason the quick fix doesn't work anymore (and I have never heard of it not working), maybe then I would look into doing the cap.
 

·
Registered
Joined
·
3 Posts
I think it could be the dimmer switch going bad. Try turning the dimmer wheel real dim. Mine if it us up on the click, it is worn enough that it will bounce off and the lights will flicker, but if I turn it low it stays steady.
 

·
Registered
Joined
·
5 Posts
This worked for me (2006 Gen 2).
Replace that weak capacitor:
The hardest part was dash disassembly:

I had to get a 12-pack of the capacitors (12 Pack Capacitor 220uF 16V 20% SMD Aluminium Electrolytic Capacitors for Arduino by HOWRIN) from Amazon (less than $5 at the time) and used only one so I have many spares.

I did this around 4 years ago, it's been good ever since.
 
1 - 4 of 4 Posts
Top