Toyota Prius Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
After 3 months of waiting for the mod kit... (Which i even forogt i ordered at this pont) I recieve the kit ... and the instructions are so unclear.

The pictures are fuzzy.


The colors in the instructions doesnt match the actual colors of the mod.



so i call.... and a lady answers... she seemed to be confused ... doesn't really understand what it means that the instructions mention different colors then whats actually in the kit.


If they dont call in 24 hours. i'm going to cotest the charge with the CC company.
 

·
Registered
Joined
·
669 Posts
Hang on folks, here we go again... :cry:

Can we not just add to the FAQ that some people think Coastal Tech is the worst thing since the Ford Pinto and other people think it is the best thing since sliced bread and HAVE DONE WITH IT??????????????????????

Sorry, I know, I'm just incorriging them... :twisted:
 

·
Registered
Joined
·
1,434 Posts
What "mod kit"? For the NAV? For goodness sake, how many photos do you need and who the heck cares if it's a different color? Plug in the 4 plugs and be done with it.
 

·
Registered
Joined
·
2,285 Posts
I don't know which mod you mean.

I pre-ordered the Nav mod and now have the actual order placed; expect in in a coupla weeks perhaps. It's a plug-in installation, so thatr is probably not it.

EV mod arrived, was a snap to install, and the instructions were perfectly clear.

Do you mean the video mod? I haven't seen that one yet.
 

·
Registered
Joined
·
1,214 Posts
What a rude subject line. Ruder yet, that he's so unclear on "what" he ordered. :evil:

Just for that, I think I'll go order something (or maybe two somethings) from Good ol' Coastal Dave, just to spite the original poster here.
 

·
Registered
Joined
·
319 Posts
BIF said:
Just for that, I think I'll go order something (or maybe two somethings) from Good ol' Coastal Dave, just to spite the original poster here.
I second that! :twisted:
 

·
Registered
Joined
·
1,661 Posts
Brian said:
BIF said:
Just for that, I think I'll go order something (or maybe two somethings) from Good ol' Coastal Dave, just to spite the original poster here.
I second that! :twisted:
Me too! I'm looking forward to the launch of the iPod thingy. :)
 

·
Registered
Joined
·
1,043 Posts
I tried to order a replacement Canary, but they do not carry them, (yet).
 

·
Registered
Joined
·
1,043 Posts
:)
 

·
Registered
Joined
·
8 Posts
I ordered an EV mod from Coastal recently and recieved it within a couple of weeks (and I'm in Canada!). Their instructions (and colours) were clear and concise and my install went smooth.
Needless to say, I'm a happy customer and I'll probably being ordering more mods from them in the future.
Keep up the good work Coastal Dave!
 

·
Registered
Joined
·
1,233 Posts
Hey Guffman, I'm installing the mod now. How do you push the orange wire all the way in? I still have a bit of metal showing and it won't budge. (also, the wire taps were hard, I almost busted the wires :cry: )
 

·
Registered
Joined
·
8 Posts
I used a very small jewellers flathead screwdriver to push on the edge of the metal clip where it joins the orange wire. If your screwdriver is small enough, it will fit right down the slot along with the orange wire, allowing you to get the clip and wire in deep. Also make sure that little white bar is pushed out about an 1/8th of an inch, to allow for the wire to make it all the way down.
It's definitely the trickiest part of the install... good luck!
 

·
Registered
Joined
·
8 Posts
Actually, moving that little white bar an 1/8th of an inch may be overstating it... it was probably closer to 1/16th of an inch that it comes out - just enough to give room for the wire to slide past. Then push the white bar back in flush once the wire is in place.

Be careful not to do what I did... I was so thrilled at getting the wires tapped and the orange wire in place so smoothly, I wanted to test it immediately before I put the dash back together. I tried powering up the car, BUT had forgot to put the grey plug with all the wires back into its slot - doh! (Coastal has a highlighted line in the instructions to NOT do this)
No damage though - other than a minor heart attack when all the gear indicators on the dash continued flashing with squares around them, and the car wouldn't start! Once I realized what I had done, I plugged in the grey wire unit, held my breath and everything (including the EV) worked fine.
 

·
Registered
Joined
·
1,233 Posts
okie. Thanks! Will try that now.
 

·
Registered
Joined
·
35 Posts
Guffman said:
I ordered an EV mod from Coastal recently and recieved it within a couple of weeks (and I'm in Canada!). Their instructions (and colours) were clear and concise and my install went smooth.
Needless to say, I'm a happy customer and I'll probably being ordering more mods from them in the future.
Keep up the good work Coastal Dave!
I ordered this kit in April and haven't heard from them at all. I had guessed that being in Canada added to the challenge of completing the order for them, knowing how Coastal Dave has some challenges with communication, which I assumed spilled over to paperwork too.

But I guess it doesn't work that way... sigh. I've also ordered separately three other items from them as well, and will also order their iPod kit when it comes out.

Anyhow - glad you got your kit and it's working well!
 

·
Registered
Joined
·
2,285 Posts
I could be wrong, but I don't believe you ordered in April; they weren't taking actual orders until June. Perhaps you "pre-ordered" which gets you a lower price, but doesn't start the 6-8 week delivery clock.
 

·
Registered
Joined
·
1,233 Posts
the pre-orders were for the nav and video kit right?

Wasn't he talking about the EV kit? I also ordered it in April and got it on Mon.
 
1 - 20 of 22 Posts
Top