Toyota Prius Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
Car: 2005 Prius with 121,000 miles.
About a year ago and during my Toyota extended warantee the heater/ac blower begain to act up. It would intermittently not start. But when it did, it would work great.

They replaced it.

During this time Toyota was the only people servicing my car. Now, the problem has come back again. I am servicing the car myself these days and I go to change out the a/c air filter.

I discover the following:
Per the pictures on John1701a.com not only should there be the HEPA filter but also some foam inside the case below the HEPA filter visable from behind the lower glove box when lowered. This is MISSING on my car.

Then when I pull out the HEPA filter I find insulation hanging down inside coming out between two sections in the back. There is so much there that when you install the HEPA filter some is BELOW the filter at the blower.

I suspect this is contaminating the blower and causing premature failure.

I removed as much as I could and collected it. Some still hangs simply because I could not get in there to pull it out.

What do you think? Can I get Toyota to fess up to this, remove the insulation or reinstall the insulation properly, add the foam filter and replace the blower?

Thanks,
Jim
 

·
Registered
Joined
·
14 Posts
Did you take any pictues before doing any further work on it? A picture is worth a thousand words and could really help support your argument.

121000 miles is quite a bit. I only have 55000 on my 2005.

Good Luck.
 
1 - 3 of 3 Posts
Top