Toyota Prius Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have an '04 Prius package 9 (NAV) with 77K miles & the screen appears to have a loose connection. Radio come & goes at its discretion; NAV sometimes works.; INFO is a hit or miss. Dealer says need a new screen-$4000. Out of warranty. 2 years old & an electical malfunction???? Toyota must have bought them from Sony. 2 years & 1 month til it failed. Anyone else having this problem? Any suggestions?
 

·
Registered
Joined
·
7,161 Posts
When you say radio comes and goes, do you mean it stops playing, and/or you can't control it from the steering wheel or the controls on the radio itself (not via the MFD)? If this is what you mean, it doesn't sound like an MFD problem to me, though it is possible. That would sound more like an intermittent connection somewhere on the AVC network (TX+/-).

Toyota did have a problem with early MFDs but it only affected the MFD and what the MFD reported. If you can (or could) toggle between energy and consumption screens via the INFO button on the steering wheel, you have the improved MFD, so the TSB for the MFD would not apply here.

If it really is the MFD, and not a bad connection as I suspect, and especially if you have the older version of the MFD, call Toyota HQ and explain that you have the symptoms described in TSB EL002-05 and a version of the MFD that was prone to this problem, and if they would cover the repair since this isn't a mileage related problem or component.

If none of this helps or applies, see if you can get an MFD from salvage, or see if there are refurbs available. There were rumors going around that refurbs were available for something like $400 or $600.

If you can't operate the radio, try disconnecting the MFD and see if the radio starts operating normally. If it does, then it might indeed be the MFD.

TSB EL002-05 has symptoms described as "Some customers may experience various malfunctions occurring with the multi–display.
Some examples are:
* “Audio Off” is shown on audio screen while audio system is playing.
* Climate control is not responsive and may say “Check connection of the
air conditioner.”
* Map, Destination buttons are inoperative and may display “External system
not connected.”
* When pressing any button on the multi–display, the system takes 5 to 10 seconds to
respond to the user’s input.
* Outside air temperature is not displayed."

The symptoms tended to appear when the system was really cold and tended to disappear when the system was warmed up.
 

·
Registered
Joined
·
582 Posts
MFD problem

If your problem is the common one, I have read that many people (post warranty) receive a refurbished MFD from Toyota for about $450. The parts are also available from salvage vehicle dismantlers.

DAS
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top