Toyota Prius Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a 2007 Prius. The other day the red triangle of death appeared along with an array of other lights on the dash. Shortly after the car acting like it was out of gas and came to a halt. Before tow came I checked codes and got p2103 which I looked up and it indicated throttle body/sensor/ECM/etc. Dealer checked it, drove it and it ran fine with no error lights, no codes. So, going forward I don’t have much confidence in the car, and will be worried the triangle, et.al. will come back. I’m picking up the car later today and will add a can of Techron hoping the throttle body just needs cleaning. Anyone have experience with this type of thing and/or the p2103 that didn’t show up for the dealer. Thanks in advance
 

·
Registered
Joined
·
23 Posts
I had something similar happen to my 2004 Prius. The red triangle of death come on intermittently. The codes indicated that the 12 Volt battery needed replacing. Replaced that battery, problem came back--ultimately it was the water pump for the hybrid engine.
 

·
Registered
Joined
·
2 Posts
I have a 2007 Prius. The other day the red triangle of death appeared along with an array of other lights on the dash. Shortly after the car acting like it was out of gas and came to a halt. Before tow came I checked codes and got p2103 which I looked up and it indicated throttle body/sensor/ECM/etc. Dealer checked it, drove it and it ran fine with no error lights, no codes. So, going forward I don’t have much confidence in the car, and will be worried the triangle, et.al. will come back. I’m picking up the car later today and will add a can of Techron hoping the throttle body just needs cleaning. Anyone have experience with this type of thing and/or the p2103 that didn’t show up for the dealer. Thanks in advance
Really appreciate the frustration with repeated Dealership visits! Similar in-and-out visits with Dealer in Ukiah CA after replacement of Inverter coolant pump and finally finding slow leak from Gas Engine Water Pump -- they didn't replace a profoundly worn water pump belt until the third comeback. (The belt was shiny worn and cracked and slipping at over 49mph + and uphill pulls.) Basic repair and maintenance items may be overlooked on such a, overall highly, reliable vehicle. "Couldn't be SUCH a simple item! But indeed it was." Hornbook mechanical inquiry still applies.
 

·
Registered
Joined
·
2 Posts
I have a 2006 Prius bought new now has 146 k on it. Acouple years ago spent 2500 on coolant system,holes in condenser they said still had red lite air worked but Later heater would not replaced. Thermosta and no light keeps working. Now my air no longer works don’t feel like spending lot of money no dealer close. Now we have new problem triangle light won’t go off has engine light also. Took it in to Orileys. Give a check all that comes up is battery problem,probably battery pack. Now icon shows all green then may jump to only two bars. Quickly recovers to at least two thirds or in awhile back to green. Often when does this hesitate slightly then gathers power. Does this mean my batteries are going bad or could be a sensor. Thanks for any ideas. I am elderly don’t want to get different car or lots of money on one so old.
 

·
Registered
Joined
·
30 Posts
I have a 2006 Prius bought new now has 146 k on it. Acouple years ago spent 2500 on coolant system,holes in condenser they said still had red lite air worked but Later heater would not replaced. Thermosta and no light keeps working. Now my air no longer works don’t feel like spending lot of money no dealer close. Now we have new problem triangle light won’t go off has engine light also. Took it in to Orileys. Give a check all that comes up is battery problem,probably battery pack. Now icon shows all green then may jump to only two bars. Quickly recovers to at least two thirds or in awhile back to green. Often when does this hesitate slightly then gathers power. Does this mean my batteries are going bad or could be a sensor. Thanks for any ideas. I am elderly don’t want to get different car or lots of money on one so old.
Sounds just like my 2007 was doing along with other dash warning lights (all were caused by the same problem). Turns out it was all caused due to the Drive Battery Pack went out. It cost me abouit $4.1K.
 

·
Registered
Joined
·
30 Posts
Sounds just like my 2007 was doing along with other dash warning lights (all were caused by the same problem). Turns out it was all caused due to the Drive Battery Pack went out. It cost me abouit $4.1K.
 
1 - 7 of 7 Posts
Top