Toyota Prius Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
ICE stops an Main battery light flashes.
I get a DLC of P1310
The following substitutions have been done with known good parts:
1- Complet HV Battery along with the relays etc inside the HV battery case, changed out 4 times with known good unit. All work fine in a second 01 Prius I have.
2- Substituted the Inverter/Converter with known good unit.
3- Substituted the Engine ECM with known good.
4- Although I have not substituted the 12 Volt battery, I have charged
it an load tested it and it is good.
I think I need some help here, I'm just about up against the wall here.
Suppose it could be the radiator cap or maybe I'm holding my mouth wrong when I turn the key? Maybe there is a ghost in the machine???
Can someone please steer me in the right direction or maybe an idea what to try next????
 

·
Registered
Joined
·
2,243 Posts
OBDII code P1310 is for the ignition coil No.3 and is set when there is no IGF signal to the ECM during engine operation.

The possible causes:
- Ignition Coil No. 3 harness is open or shorted
- Ignition Coil No. 3 circuit poor electrical connection
- Faulty Ignition Coil No. 3
- Faulty Engine Control Module (ECM)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
My problem seems to be in the charging of the HV Battery.
I take a known good HV Battery assembly out of a working Prius an substitute
it in the problem Prius. It starts an the energy flow screen shows the ICE charging the HV Battery, problem it is discharging the Battey rather than harging it.
The HV Battery is drained pretty fast an the red triangle comes on telling me I have a HV Battery problem. It's like a reverse polarity where the charging is back words and is discharging rather that charging the HV Battery.
 
1 - 3 of 3 Posts
Top