2007 Prius Engine Stops at 70mph - Toyota Prius Forum : Prius Online Toyota Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 09-13-2015, 11:08 AM Thread Starter
Junior Member
 
Join Date: Sep 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default 2007 Prius Engine Stops at 70mph

Last night I was driving on freeway and the engine simply quit. All the lights & power steering went out. I was able to put on 4-way flashers and coast to the side of the road without incident. Nothing but the flashers worked in the car, tried to turn on, but nothing. Eventually got the car towed - of course without being able to shift to neutral.

Cannot find anything about this, but assume it must have happened to someone before. Does anyone have any insight on this? Thanks.
Mark Harner is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Prius 2007 - vibrations on idle gas engine rpms alexk76 Engines and Technical Discussion 0 02-02-2015 04:22 PM
engine stops climbing up a hill sgallman Engines and Technical Discussion 3 08-22-2014 02:59 AM
01 Prius ICE Starts, Runs a few seconds an stops 1ready2 Toyota Prius - Technical Chat 2 07-02-2013 08:24 AM
Regeneration Stops when hitting Bump - ?? Frank06 Toyota Prius - Technical Chat 4 03-09-2006 03:13 PM
shuddering at stops leebek Toyota Prius - Technical Chat 12 02-21-2004 06:02 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome