2007 Toyota Prius Issues after Inverter pump recall. - Toyota Prius Forum : Prius Online Toyota Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 04-25-2015, 04:54 PM Thread Starter
Junior Member
 
Join Date: Apr 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy 2007 Toyota Prius Issues after Inverter pump recall.

Hey Everyone!

I've been having an issue for months with my 2007 Prius. I took it in for an inspection, and while there i was told the brakes and rotors needed replaced, and of course the tires were worn down at 60K, so i replaced them as well with Goodyear Assurance Fuelmax tires, and have them inflated to the max side pressure of 52 psi. Brakes are Toyota Genuine pads and rotors. It had Goodyear Assurance tires on it when i replaced them with the same thing.

After recieving the car back, it has seemed to lost it's power.. if that makes sense. Seems as if the gas pedal is touchier, engine runs longer, and doesn't seem to roll near as well down hills and regenerate like it used to! I used to bang out some excellent fuel economy up near 60MPG over the spring and summer months. Now the poor thing seems to average about 40 mpg. Winter was just awful with the thing. And of course with all of this it seems to have no power on inclines on the highway or going up mountainsides like it used to.

Just not sure what else i'm not thinking of, i've had it back to the deal multiple times, and they just keep saying it's operating as normal.

I've also kind of did my own test on the HV battery, just sitting in a parking lot with the car in park, engine off and watching the bars go down on the monitor. I believe it had 7 bars and it was green, and sitting there for almost 20 min with nothing on but the power button and in park, the bars went from 7 to about 4 and then to 3 just above the purple level in that time period.

Not sure what else i am not thinking of, it's been stressing me!

Thanks for any help!!!
dj4life2004 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-29-2015, 03:16 AM
Member
 
Join Date: Apr 2005
Location: Western WA
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

That is a good way to see if your 12Volt battery is having a problem. If the rate of drain on the Traction battery does not slow down after a while then have the 12Volt battery checked. Having a low 12Volt battery can lead to strange behavior when starting the car.

Also check for any brake drag on any of the wheels. After driving for a few minutes you might stop and see if any of the brakes seem hot. Be careful NOT to BURN yourself. If you have an IR Temperature gauge point the laser at the brake drums and rotors. If you have disk brakes on all wheels, check the center of rear wheels where the parking brakes are located.
fdret44 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Prius - inverter went after the update/recall Elzbieta Nowakowski Electronics and Audio 1 07-21-2014 08:20 PM
Inverter & Electric Water Pump Failure Phoenix Toyota Prius - Technical Chat 23 02-15-2012 06:29 PM
Service Campaign 2004 - 2007 hybrid water pump replacement jeromep Toyota Prius - Technical Chat 3 02-09-2012 10:41 AM
2007 PRIUS W/ 220,000 miles and power issues jsanch Toyota Prius - Technical Chat 6 08-07-2011 03:15 PM
Inverter coolant pump failed Thomme Toyota Prius - Technical Chat 5 04-28-2008 02:01 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome