Check Engine Light - Toyota Prius Forum : Prius Online Toyota Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 08-30-2006, 10:53 PM Thread Starter
Junior Member
 
Join Date: Jul 2006
Location: Brick, NJ
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default Check Engine Light

i have an 06 with 4,500 miles on it. Last night while driving on rain soaked roads, the Check Engine Light appears and stays on. I thought maybe something got wet and set it off, but it stayed on all day today as well.

Dealer asks me if i just got gas (i hadn't) and says it probably has something to do with emisions and to bring it in on Tuesday.

I'm disappointed that the car has to go back to the dealer after just 6 weeks!

Any thoughts on what it may be??
orangewingnut is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-31-2006, 12:13 AM
Moderator
 
Join Date: Aug 2004
Location: Tampa Bay
Posts: 7,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to DanMan32 Send a message via MSN to DanMan32
Default

Without codes, can't say. Considering the environment that occured was after driving in heavy rain it sounds like a sensor or a connector has gotten wet or damaged. It may dry up eventually, or it might not.

Many auto parts stores will check for DTCs for you at a small or no charge. This is a good thing, since it takes no time to retrieve the codes, and many times the problem is a very minor one requiring only owner intervention. For example, my parents' saturn triggered a DTC. Turned out that one tire was a tad low, so the ABS triggered a code due to the wheel speed difference. Now whether Saturn intended that to be a detection of a tire inflation problem, or if the symptom the code indicated was incidental to the cause of a low tire, I can't say.

But once you get the codes, we can look them up and give some ideas as to what the problem might be.

Otherwise, its like saying you have a pain, without saying where the pain is.
DanMan32 is offline  
post #3 of 8 (permalink) Old 08-31-2006, 04:36 PM
Senior Member
 
Join Date: Mar 2005
Posts: 582
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default CEL

Some 2004s had a bad hood seal, and water could get down to the ignitors. Maybe this can happen rarely to 2006s? I guess it could lead to a misfire code.

DAS
tochatihu is offline  
post #4 of 8 (permalink) Old 08-31-2006, 04:53 PM
Senior Member
 
firepa63's Avatar
 
Join Date: Jun 2004
Posts: 2,243
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Default

Are you sure it's a check engine light and not the maintenance required light? From the odometer reading in your post, you are close to the maintenance required light coming on.
firepa63 is offline  
post #5 of 8 (permalink) Old 08-31-2006, 06:12 PM
Senior Member
 
Join Date: Feb 2005
Location: SoCal Pasadena Environs
Posts: 670
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Quote:
Originally Posted by firepa63
Are you sure it's a check engine light and not the maintenance required light? From the odometer reading in your post, you are close to the maintenance required light coming on.
Which it does when it thinks you need an oil change... based on the odometer reading alone...

2005 Driftwood Pearl Pkg #6
\"The Pod Racer\"
Astrowoman is offline  
post #6 of 8 (permalink) Old 08-31-2006, 11:34 PM
Super Moderator
 
Join Date: Sep 2005
Location: Bolton, Connecticut
Posts: 702
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Hi, there, firepa63 & Astrowoman,

Orangewingnut did say : the light "appears and STAYS ON". The "maintenance required" light only appears briefly at power-up from the 4,500 to 5,000 miles increment, & then after 5,000 miles from each previous re-set it stays on until the person doing your oil chg & tire rotation re-sets it again. That's the way it works for the '04/'05, so I don't think that's what's going on with his '06 unless Toyota chg'd the way the "maintenance required" light works between the 4,500 & 5,000 mile marks. And let's NOT forget he did say : "Cheeck Engine Light".

Maybe in the absence of confirmation that it's the "Check Engine Light", somebody with an '06 can tell us if their "maintenance required" light works any differently than on the '04/'05's.

Ken (in Bolton,Ct)

Ken (in Bolton,Ct) 2005 Pkg #4 (AM)
Ct. Ken V is offline  
post #7 of 8 (permalink) Old 09-01-2006, 10:36 PM Thread Starter
Junior Member
 
Join Date: Jul 2006
Location: Brick, NJ
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default

firepa,
actually both light up at start up. The check engine light stays on and the service interval light blinks a few times and then goes out as a reminder to change my oil soon.

ct.kenv

according to my 06 manual, the light will blink at start up as you approach 5000 miles and then remain on when you reach and exceed 5000 until it is reset.

all,

funny thing though, i got gas this morning and then realized a little while after that the check engine light went out
orangewingnut is offline  
post #8 of 8 (permalink) Old 09-02-2006, 11:32 AM
Senior Member
 
firepa63's Avatar
 
Join Date: Jun 2004
Posts: 2,243
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Default

orangewingnut, it's possible that your gas cap was not tight. I think that will cause a check engine light. It may take a refill or two to clear the codes, thus clearing the light. I'm quite sure I read about this on the forum a year or more ago.
firepa63 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Master Warning Light / Check Engine Light - then off holitza Prius - Q & A 1 07-31-2011 08:30 AM
check engine light on sherner Prius - Technical 2 05-28-2008 03:36 PM
Check engine light wayneswhirld Prius - Technical 7 02-25-2007 01:01 AM
check engine light brian lym Prius - Technical 1 09-20-2004 10:11 PM
check engine light at 30,500 miles PriusJim Prius - General 1 02-04-2004 03:51 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome